Support Ending for Internet Explorer 8, 9, 10

Effective today (January 12), Microsoft no longer supports the older versions of its Internet Explorer software: Versions 8, 9 and 10. What does that mean if you are still using an old version? You will likely still be able to use the MLS and other websites without issue for some time. However, as time goes on and the MLS and other systems are updated, you could run into issues. But more importantly, Microsoft will no longer publish security updates for these browser versions, making users still on them more vulnerable to malware and other threats.

If you are on Internet Explorer and want to check your version, select “About Internet Explorer” from the Help menu or the gear icon in the upper right corner of the browser. If you are on one of the now unsupported versions, contact your IT department or go to the Microsoft Internet Explorer Download Center. If you need help, contact our Help Desk at help@northstarmls.com or 651-251-5456 (toll free 1-877-251-5455), M-F, 8:00 am to 5:00 pm.

For more information, we recommend this CNN Money article and this Wired.com article.

Print Friendly, PDF & Email
Tagged with: , , , , ,

Leave a Reply

Your email address will not be published. Required fields are marked *

*